
Паскаль. Дан текст. Написать программу, которая подсчитывает количество слов, в тексте учитывая,
что между словами может быть по несколько пробелов.

Ответы на вопрос

begin
var s:=ReadlnString('Вводите:');
Write('Кол-во слов: ',s.ToWords.Count)
end.
Тестовое решение
Вводите: А роза упала на лапу Азора
Кол-во слов: 6



Для подсчета количества слов в тексте, учитывая возможное наличие нескольких пробелов между словами, можно написать программу на языке Паскаль. Вот пример такой программы:
```pascal program CountWords; uses crt;
function CountWordsInText(text: string): integer; var count: integer; i: integer; begin count := 0; i := 1; // Пропускаем начальные пробелы while (i <= Length(text)) and (text[i] = ' ') do i := i + 1; // Подсчитываем слова while i <= Length(text) do begin // Находим начало слова while (i <= Length(text)) and (text[i] = ' ') do i := i + 1; // Если достигнут конец текста, выходим из цикла if i > Length(text) then break; // Увеличиваем счетчик слов count := count + 1; // Находим конец слова while (i <= Length(text)) and (text[i] <> ' ') do i := i + 1; end; CountWordsInText := count; end;
var text: string; wordCount: integer; begin clrscr; // Вводим текст writeln('Введите текст:'); readln(text); // Подсчитываем количество слов wordCount := CountWordsInText(text); // Выводим результат writeln('Количество слов в тексте: ', wordCount); readln; end. ```
Программа начинается с объявления функции `CountWordsInText`, которая принимает текст в качестве аргумента и возвращает количество слов в тексте. Затем программа объявляет переменные `text` для хранения введенного текста и `wordCount` для хранения результата подсчета слов.
В основной части программы происходит ввод текста с помощью `readln`, вызов функции `CountWordsInText` для подсчета слов и вывод результата с помощью `writeln`.
Примечание: Данная программа не учитывает знаки препинания и специальные символы при подсчете слов. Она считает последовательности символов, разделенные пробелами, как отдельные слова.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili