помогите пожалуйста сделать программу в фри паскале :сначало надо найти сумму
положительных\отрцательных и потом их сложить помогитеОтветы на вопрос
var ch,so,sp:integer;
begin
for i:=1 to 4 do
begin
if ch>0 then sp:=s+ch
else
so:=so+ch;
end;
writeln(so+sp);
end.
как то так
Конечно, я могу помочь вам написать программу на языке программирования Free Pascal для выполнения задачи, которую вы описали. Вот пример простой программы, которая находит сумму положительных и отрицательных чисел, а затем их суммирует:
```pascal program SumPositiveNegative;
var n, num, positiveSum, negativeSum: integer;
begin // Инициализация сумм positiveSum := 0; negativeSum := 0;
// Ввод количества чисел write('Введите количество чисел: '); readln(n);
// Ввод чисел и вычисление сумм for i := 1 to n do begin write('Введите число ', i, ': '); readln(num);
if num > 0 then positiveSum := positiveSum + num else if num < 0 then negativeSum := negativeSum + num; end;
// Вывод результатов writeln('Сумма положительных чисел: ', positiveSum); writeln('Сумма отрицательных чисел: ', negativeSum); writeln('Сумма всех чисел: ', positiveSum + negativeSum);
readln; end. ```
Обратите внимание, что в этой программе мы используем переменные `positiveSum` и `negativeSum`, чтобы отслеживать сумму положительных и отрицательных чисел соответственно. Затем мы выводим обе суммы, а также их общую сумму.
Вы можете скопировать этот код в среду программирования Free Pascal и выполнить его, чтобы увидеть результат. Пожалуйста, учтите, что этот код предполагает ввод чисел с клавиатуры.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
