Друзьяяя!!!! Помогите написать программу, которая считывает три числа день, месяц и год, и выводит
дату следующего дня. Високосный год не учитывать. программа c++Ответы на вопрос
int main()
{
float x, y, z;
setlocale (LC_ALL, "Russian");
std::cout << "Введите день: ";
std::cin >> x;
std::cout << "Введите месяц: ";
std::cin >> y;
std::cout << "Введите год: ";
std::cin >> z;
std::cout << "Следующий день: " << x+1 << "." << y << "." << z << std::endl;
system("pause");
}
Я нашел несколько результатов по вашему запросу. Вот один из них, который содержит решение вашей задачи на языке C++:
```c++
#include
int main() { int day, month, year; // объявляем переменные для дня, месяца и года cin >> day >> month >> year; // считываем их с клавиатуры day++; // увеличиваем день на единицу if (month == 2 && day > 28) // если месяц февраль и день больше 28 { day = 1; // то день становится 1 month++; // и месяц увеличивается на единицу } else if ((month == 4 || month == 6 || month == 9 || month == 11) && day > 30) // если месяц апрель, июнь, сентябрь или ноябрь и день больше 30 { day = 1; // то день становится 1 month++; // и месяц увеличивается на единицу } else if (day > 31) // если день больше 31 { day = 1; // то день становится 1 month++; // и месяц увеличивается на единицу } if (month > 12) // если месяц больше 12 { month = 1; // то месяц становится 1 year++; // и год увеличивается на единицу } cout << day << " " << month << " " << year << endl; // выводим дату следующего дня return 0; } ```
Надеюсь, это поможет вам решить вашу задачу. Если вам нужна дополнительная помощь, я могу предложить вам другие источники информации или сгенерировать для вас другие виды контента, такие как стихи, рассказы, эссе, песни и т.д.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
