Помогите пожалуйста решить задачу в pascal ABC. Очень срочно нужно Составьте программу, позволяющую
определить, будет ли введённая строка перевёртышем после удаления из неё всех пробеловОтветы на вопрос
var a, b: string;
i: longint;
begin
clrscr;
write('Введите слово: ');
readln(a);
b := '';
for i := 1 to length(a) do
b := a[i] + b;
if a = b then
write('перевертыш')
else
write('не перевертыш');
readln;
end.
Конечно, я могу помочь вам с задачей на языке Pascal ABC. Вам нужно написать программу, которая определит, является ли введенная строка перевертышем после удаления из нее всех пробелов. Вот пример решения:
```pascal program CheckPalindrome; var inputString, reversedString: string; i: integer; begin // Ввод строки writeln('Введите строку:'); readln(inputString); // Удаление пробелов из строки for i := 1 to length(inputString) do begin if inputString[i] <> ' ' then reversedString := reversedString + inputString[i]; end; // Проверка, является ли строка перевертышем if reversedString = reverseString(reversedString) then writeln('Введенная строка является перевертышем.') else writeln('Введенная строка не является перевертышем.'); readln; end. ```
В этой программе мы сначала вводим строку с помощью `readln`. Затем мы проходим по каждому символу строки и добавляем его в переменную `reversedString`, если символ не является пробелом. Затем мы сравниваем `reversedString` с перевернутой версией самой себя, используя функцию `reverseString`. Если они равны, то введенная строка является перевертышем, иначе она не является перевертышем.
Примечание: В этой программе используется функция `reverseString`, которая не является стандартной функцией в Pascal ABC. Если вы используете другую среду разработки, убедитесь, что у вас есть функция для переворачивания строки. Если нет, вы можете написать свою собственную функцию для переворачивания строки.
Надеюсь, это поможет вам решить вашу задачу! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
