
Составьте программу для ввода с клавиатуры в массив 7 целых чисел и вывода этих чисел в обратном
порядке.

Ответы на вопрос

Используется язык pascal
program pr;
var
mas:array[1..7] of integer;
i:integer;
begin
writeln('Вводим значения в массив');
for i:=1 to 7 do readln (mas[i]);
writeln('Выводим значения из массива');
for i:=7 downto 1 do writeln(mas[i]);
readln;
end;



Программа для ввода и вывода чисел в обратном порядке
Для решения данной задачи можно написать программу на языке программирования, который поддерживает массивы и циклы. Возьмем, например, язык JavaScript.
```javascript // Создаем массив для хранения чисел var numbers = [];
// Вводим числа с клавиатуры и добавляем их в массив for (var i = 0; i < 7; i++) { var number = parseInt(prompt("Введите число:")); numbers.push(number); }
// Выводим числа в обратном порядке for (var i = numbers.length - 1; i >= 0; i--) { console.log(numbers[i]); } ```
В данной программе мы создаем пустой массив `numbers`, в который будем добавлять числа, введенные с клавиатуры. Затем с помощью цикла `for` мы запрашиваем у пользователя 7 чисел и добавляем их в массив с помощью метода `push()`. После этого мы снова используем цикл `for`, но на этот раз проходим по массиву в обратном порядке и выводим числа на экран с помощью функции `console.log()`.
Таким образом, программа позволяет ввести 7 чисел с клавиатуры и вывести их в обратном порядке.
Примечание: Приведенный код является примером на языке JavaScript и может быть адаптирован для использования в других языках программирования.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili