 
Помогите написать программу в с++ . Очень надо. В произвольном тексте программа выводит самое
короткое слово. 0
        0
         0
        0
    Ответы на вопрос
 
        #include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int main(int argc, char** argv) {
int i=0,j=0,l=0;
char st[200];
char ch=' ';
cout<<" string: "; gets(st); cout<<endl;
string mins;
int mn,bgmn,emn,tek;
mn=strlen(st); bgmn=0;
while (true) {
while ((st[j]!=ch) and (j<strlen(st))) j++;
tek=j-l;
for (int i=l; i<j; i++)
{ if (tek<mn) { mn=tek; bgmn=l; emn=j-1; } }
if (j==strlen(st)) break;
j++; l=j;
}
//запись строки
for (int i=bgmn; i<=emn; i++) mins=mins+st[i];
cout<<"short word: "<<mins<<endl<<endl;
system("pause");
return(0);
}
 0
                    0
                     0
                    0
                 
            Конечно, я могу помочь вам написать программу на C++, которая будет выводить самое короткое слово в произвольном тексте. Вот пример такой программы:
```cpp
#include 
std::string findShortestWord(const std::string& text) { std::istringstream iss(text); std::string word, shortestWord; int shortestLength = INT_MAX;
while (iss >> word) { int length = word.length(); if (length < shortestLength) { shortestLength = length; shortestWord = word; } }
return shortestWord; }
int main() { std::string text; std::cout << "Введите произвольный текст: "; std::getline(std::cin, text);
std::string shortestWord = findShortestWord(text); std::cout << "Самое короткое слово: " << shortestWord << std::endl;
return 0; } ```
В этой программе мы используем функцию `findShortestWord`, которая принимает произвольный текст в качестве аргумента и возвращает самое короткое слово в тексте.
Функция `findShortestWord` использует `std::istringstream` для разделения текста на отдельные слова. Затем она проходит по каждому слову и сравнивает его длину с текущей самой короткой длиной. Если длина слова меньше текущей самой короткой длины, то оно становится новым самым коротким словом.
В функции `main` мы считываем произвольный текст с помощью `std::getline` и передаем его в функцию `findShortestWord`. Затем выводим полученное самое короткое слово на экран.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			