Написать программу которая будет находить произведение чётных чисел из 3 введенных чисел
Ответы на вопрос
Ответ:
#include <iostream>
void main()
{
int mas[3];
int result = 1;
for int(i=0; i<3; i++)
std::cin>>mas[i];
for int(i=0; i<3; i++)
if(mas[i]%2==0)
result = result * mas[i]
std::cout<<result<<endl;
system("pause");
}
Объяснение:
Я могу помочь вам написать программу, которая будет находить произведение чётных чисел из трёх введённых чисел. Вот один из возможных вариантов решения этой задачи на языке Python:
```python # Вводим три числа с клавиатуры и преобразуем их в целые числа a = int(input("Введите первое число: ")) b = int(input("Введите второе число: ")) c = int(input("Введите третье число: "))
# Создаем переменную для хранения произведения четных чисел product = 1
# Проверяем, является ли первое число четным if a % 2 == 0: # Если да, то умножаем произведение на это число product = product * a
# Повторяем ту же логику для второго и третьего чисел if b % 2 == 0: product = product * b
if c % 2 == 0: product = product * c
# Выводим результат на экран print("Произведение четных чисел равно", product) ```
Эта программа считывает три числа с клавиатуры, проверяет, являются ли они четными, и если да, то перемножает их. Затем она выводит полученное произведение на экран. Если среди трех чисел нет ни одного четного, то произведение будет равно 1, так как это нейтральный элемент для умножения.
Надеюсь, это поможет вам решить вашу задачу. Если у вас есть еще вопросы, я буду рад ответить на них.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
