Вопрос задан 10.01.2020 в 01:16. Предмет Информатика. Спрашивает Гуляева Кира.

Решить в Паскале (без массива) №1 Составьте не менее трёх вариантов программы определения

наименьшего их трех данных чисел. №2 Составить программу сортировки по возрастанию значений трёх переменных : А,В,С . №3 Заданы Размеры а,в прямоугольного отверстия x,y,z кирпича. Определить пройдет ли кирпич через отверстие .
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот примеры программ на языке Pascal для решения указанных задач:

№1: Определение наименьшего из трех чисел

```pascal program MinOfThreeNumbers; var a, b, c, min: integer; begin writeln('Введите три числа:'); readln(a, b, c);

min := a; // Предположим, что минимальное число - a

if b < min then min := b; // Если b меньше, чем текущее минимальное, присваиваем его if c < min then min := c; // Если c меньше, чем текущее минимальное, присваиваем его

writeln('Наименьшее число: ', min); end. ```

№2: Сортировка трех переменных по возрастанию

```pascal program SortThreeVariables; var a, b, c, temp: integer; begin writeln('Введите три числа:'); readln(a, b, c);

if a > b then begin temp := a; a := b; b := temp; end;

if a > c then begin temp := a; a := c; c := temp; end;

if b > c then begin temp := b; b := c; c := temp; end;

writeln('Отсортированные числа по возрастанию: ', a, ' ', b, ' ', c); end. ```

№3: Определение прохождения кирпича через отверстие

```pascal program BrickThroughHole; var a, b, x, y, z: integer; begin writeln('Введите размеры отверстия (x, y):'); readln(x, y); writeln('Введите размеры кирпича (a, b, z):'); readln(a, b, z);

if ((a <= x) and (b <= y)) or ((a <= y) and (b <= x)) or ((a <= x) and (z <= y)) or ((a <= y) and (z <= x)) or ((b <= x) and (z <= y)) or ((b <= y) and (z <= x)) then writeln('Кирпич пройдет через отверстие.') else writeln('Кирпич не пройдет через отверстие.'); end. ```

Эти программы предполагают ввод значений с клавиатуры и используют конструкции условий (`if-else`), чтобы выполнить соответствующие действия в зависимости от условий, заданных в задачах.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос