Вопрос задан 28.05.2018 в 10:53.
Предмет Информатика.
Спрашивает Чернакова Валерия.
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые
значения. Напишите программу, которая находит и выводит номер третьего положительного элемента массива (если из массива вычеркнуть все неположительные элементы, этот элемент стоял бы в получившемся массиве на третьем месте). Если в массиве меньше, чем три положительных элемента, вывести сообщение об этом.Ответы на вопрос
Отвечает Попов Кирилл.
Const n=30;
var a:array[1..n] of integer;
k,i:integer;
begin
for i:=1 to n do begin
a[i]:=random(21)-10;
write(a[i],' ');
end;
writeln;
k:=0; i:=0;
while (i<n)and(k<3) do
begin
i:=i+1;
if a[i]>0 then k:=k+1;
end;
if k=3
then writeln('Номер третьего положительного элемента = ',i)
else writeln('В массиве нет 3 положительных элементов');
end.
Пример (для n=20):
-4 -10 3 -4 6 1 -9 4 -10 -8 7 7 0 -2 9 -4 -10 -3 1 -2
Номер третьего положительного элемента = 6
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
