Вопрос задан 06.01.2020 в 10:30.
Предмет Информатика.
Спрашивает Маленкова Анна.
Написать программу, которая переводит из двоичной в десятичную систему счисления на С# или С.
Ответы на вопрос
Отвечает Тимкина Соня.
Using System;
public class Test
{
public static void Main()
{
int n=0, d=1;
Console.WriteLine("Введите двоичное число: ");
string s = Console.ReadLine();
for (int i=0; i<s.Length; i++){
if (s[i]=='1') n += d;
d *= 2;
}
Console.WriteLine("n = {0}", n);
Console.ReadKey();
}
}
Пример:
Введите двоичное число: 1110111
n = 119
public class Test
{
public static void Main()
{
int n=0, d=1;
Console.WriteLine("Введите двоичное число: ");
string s = Console.ReadLine();
for (int i=0; i<s.Length; i++){
if (s[i]=='1') n += d;
d *= 2;
}
Console.WriteLine("n = {0}", n);
Console.ReadKey();
}
}
Пример:
Введите двоичное число: 1110111
n = 119
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
