Вопрос задан 12.07.2019 в 22:03.
Предмет Информатика.
Спрашивает Джейдан Эдэм.
Составить программу для нахождения площади ромба по стороне а и острому углу f (угол предварительно
переведите в радианы t = f · 3,14 : 180) по формуле S = a 2 sin tОтветы на вопрос
Отвечает Гагарин Васик.
Var
a, f, t, S: real;
begin
Write('Введите длину стороны ромба: '); Readln(a);
Write('Введите величину острого угла ромба в градусах: '); Readln(f);
t := f * pi / 180;
S := sqr(a) * sin(t);
Writeln('Площадь ромба равна ', S, ' кв.ед.')
end.
Тестовое решение:
Введите длину стороны ромба: 14.3
Введите величину острого угла ромба в градусах: 58.7
Площадь ромба равна 174.728286173858 кв.ед.
a, f, t, S: real;
begin
Write('Введите длину стороны ромба: '); Readln(a);
Write('Введите величину острого угла ромба в градусах: '); Readln(f);
t := f * pi / 180;
S := sqr(a) * sin(t);
Writeln('Площадь ромба равна ', S, ' кв.ед.')
end.
Тестовое решение:
Введите длину стороны ромба: 14.3
Введите величину острого угла ромба в градусах: 58.7
Площадь ромба равна 174.728286173858 кв.ед.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
