
Вопрос задан 12.07.2019 в 19:52.
Предмет Информатика.
Спрашивает Рахматуллина Алсина.
1. Напишите программу, которая определяет сумму цифр 3-х числа. Например : 5+4div+8=17 2. Напишите
программу , которая произведение чисел 3-х ( 548 ➡️ 160) Помогите пожалуйста

Ответы на вопрос

Отвечает Головкина Дарья.
//PascalABC.Net 3.0, сборка 1053
var
n,s,p:integer;
begin
Write('Введите натуральное трехзначное число: '); Read(n);
s:=(n div 100)+((n div 10) mod 10)+(n mod 10);
p:=(n div 100)*((n div 10) mod 10)*(n mod 10);
Writeln('Сумма цифр числа равна ',s);
Writeln('Произведение цифр числа равно ',p)
end.
Тестовое решение:
Введите натуральное трехзначное число: 548
Сумма цифр числа равна 17
Произведение цифр числа равно 160
var
n,s,p:integer;
begin
Write('Введите натуральное трехзначное число: '); Read(n);
s:=(n div 100)+((n div 10) mod 10)+(n mod 10);
p:=(n div 100)*((n div 10) mod 10)*(n mod 10);
Writeln('Сумма цифр числа равна ',s);
Writeln('Произведение цифр числа равно ',p)
end.
Тестовое решение:
Введите натуральное трехзначное число: 548
Сумма цифр числа равна 17
Произведение цифр числа равно 160


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili