Вопрос задан 12.07.2019 в 14:05.
Предмет Информатика.
Спрашивает Курмангалиулы Данияр.
Ввести с клавиатуры массив из N вещественных чисел. Найти разность максимального и минимального
элементов.(Составить программу Pascal)Ответы на вопрос
Отвечает Семенова Евгения.
Uses crt;
const
N = 10;
var
a : array [1..N] of Real;
i : Integer;
max, min : Real;
begin
clrscr;
for i := 1 to N do
begin
Write('a[', i,'] = ');
Readln(a[i]);
end;
max := a[1];
min := a[1];
for i := 2 to N do
begin
if max < a[i] then max := a[i];
if min > a[i] then min := a[i];
end;
Writeln(max - min:0:3);
Readln;
end.
const
N = 10;
var
a : array [1..N] of Real;
i : Integer;
max, min : Real;
begin
clrscr;
for i := 1 to N do
begin
Write('a[', i,'] = ');
Readln(a[i]);
end;
max := a[1];
min := a[1];
for i := 2 to N do
begin
if max < a[i] then max := a[i];
if min > a[i] then min := a[i];
end;
Writeln(max - min:0:3);
Readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
