Вопрос задан 26.05.2018 в 03:00.
Предмет Информатика.
Спрашивает Кузнецов Степан.
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет
сколько из этих чисел удовлетворяет условию:сумма значений цифр десятичной записи числа равно 10Ответы на вопрос
Отвечает Андреевна Анастасия.
Pascal
const
n = 100; // Максимальное число элементов
var a : array [1..n] of integer;
L,i,c,s,k : integer;
begin
L := 1;
c := 10;
while c <> 0 do
begin
readln (c);
a[L] := c;
L := L + 1;
end;
l := l -1;
k := 0;
for i := 1 to L do
begin
c := a[i];
s := 0;
while c <> 0 do
begin
s := s + c mod 10;
c := c div 10;
end;
if s = 10 then
k := k + 1;
end;
writeln ();
writeln (k);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
