Вопрос задан 24.05.2018 в 15:35.
Предмет Информатика.
Спрашивает Бекмаганбетов Рамазан.
Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера
массива и вычисляется по формуле ( i+5)^2). Параметр n должен задавать пользователь. Напишите программу, вычисляющую сумму значений элементов одномерного массива и среднее арифметическое введенных n чисел. Вывод оформите в строку через пробел.Ответы на вопрос
Отвечает Парфенова Николь.
Uses crt;
const m=1000;
var a:array[1..m] of integer;
i,s,n:integer;
sr:real;
begin
readln(n);
writeln;
s:=0;
for i:=1 to n do
begin
a[i]:=(i+5)*(i+5);
writeln(a[i]);
s:=s+a[i];
end;
writeln;
sr:=s/n;
writeln(s,' ',sr);
end.
Отвечает Шевцова Карина.
Var
a: array[1..100] of integer;
i, s, n: integer;
begin
readln(n);
for i := 1 to n do begin
a[i] := (i + 5) * (i + 5);
write(a[i],' ');
s := s + a[i];
end;
writeln;
writeln(s, ' ', s / n);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
