Вопрос задан 27.06.2019 в 03:56.
Предмет Информатика.
Спрашивает Подугорова Ангелина.
Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят
через K дней, начиная с первого января 2008 года. Напомним, что это был вторник.Язык : Паскаль. Целое число K (0 <= K <= 1000) Пример: ------------------------------------------------------------------------------------- Входа: | Выхода: 0 | Tuesday, 01.01 5 | Sunday, 06.01 ------------------------------------------------------------------------------------Ответы на вопрос
Отвечает DELETED.
// Я очень, невероятно не люблю изобретать велосипеды
//Поэтому воспользуемся уже встроенным типом DataTime
//Pascal ABC.NET Версия 2.2 Сборка 790
uses system;
var k:integer;
startSys:DateTime; //сабж
m,d:string;
begin;
readln(k);
startSys:=startSys.AddYears(2007); //добавляет года к старту, отсчёт от 1
startSys:=startSys.AddDays(k); //добавляет кол-во дней
//тип сам определяет високосный год или нет
writeln(startSys.DayOfWeek,', ',startSys.Day,'.',startSys.Month); //вывод
end.
//Поэтому воспользуемся уже встроенным типом DataTime
//Pascal ABC.NET Версия 2.2 Сборка 790
uses system;
var k:integer;
startSys:DateTime; //сабж
m,d:string;
begin;
readln(k);
startSys:=startSys.AddYears(2007); //добавляет года к старту, отсчёт от 1
startSys:=startSys.AddDays(k); //добавляет кол-во дней
//тип сам определяет високосный год или нет
writeln(startSys.DayOfWeek,', ',startSys.Day,'.',startSys.Month); //вывод
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
