Вопрос задан 26.06.2019 в 03:08. Предмет Информатика. Спрашивает Каурова Маргарита.

Срочно! паскаль (с использованием операторов if и elsе) Напишите программу, которая по введенным с

клавиатуры числам e, f, g, h и w будет вычислять значение коэффициента a, b и c квадратного уравнения по предлагаемым формулам, а также значение дискриминанта D, решать это квадратное уравнение и выдавать результаты его решения. a=7e-f/2, b=√((g+e)^2+h/w), c=|w^2-h| sin⁡a, Где дискриминант D=b^2-4ac; корни уравнения x_1,2=(-b±√D)/2a. отладьте программу на следующем примере: е=2, f= -5, g=-5, h=3, w=2 a=16.5 b=3.24037 c=-0.711785 D=57.4778 x1=0.131547 x2=-0.327933
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Архипова Карина.
Var
   e,f,g,h,w,a,b,c,D:real;
begin
readln(e);
readln(f);
readln(g);
readln(h);
readln(w);
a:=7*e-f/2;
b:=sqrt(sqr(g+e)+h/w);
c:=abs(sqr(w)-h)*sin(a);
D:=sqr(b)-4*a*c;
writeln('a = ',a);
writeln('b = ',b);
writeln('c = ',c);
writeln('D = ',D);
if(D<0) then writeln('Корней нет')
else if(D = 0) then
  writeln('x = ',-b/(2*a))
else
begin
  writeln('x1 = ',(-b+sqrt(D))/(2*a));
  writeln('x2 = ',(-b-sqrt(D))/(2*a));
end;
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос