Вопрос задан 24.06.2019 в 03:23.
Предмет Информатика.
Спрашивает Аминов Дмитрий.
Составить программу,которая формирует список L, включив в него по одному разу элементы,которые
входят одновременно в оба списка L1 и L2. Pascal abc.netОтветы на вопрос
Отвечает Кульченко Алёна.
// PascalABC.NET 3.0, сборка 1088
begin
var L1:=new List<integer>;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List<integer>;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List<integer>;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]
begin
var L1:=new List<integer>;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List<integer>;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List<integer>;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
