Вопрос задан 19.06.2019 в 20:20.
Предмет Информатика.
Спрашивает Летаев Максим.
Написать программу в Паскаль:1)Составьте программу, которая по заданному году и номеру месяца
определит кол-во дней в этом месяце.2)Для любого 2-ух значного числа, вывести его значение в словесной форме.Ответы на вопрос
Отвечает Карпов Максим.
1)
var y,m,d:integer;
begin
read(y,m);
case m of
1,3,5,7,8,10,12: d:=31;
4,6,9,11: d:=30;
2:if(y mod 4<>0) then d:=28 else
if(y mod 100<>0) then d:=29 else
if(y mod 400<>0) then d:=28 else
d:=29;
end;
writeln(d);
end.
var y,m,d:integer;
begin
read(y,m);
case m of
1,3,5,7,8,10,12: d:=31;
4,6,9,11: d:=30;
2:if(y mod 4<>0) then d:=28 else
if(y mod 100<>0) then d:=29 else
if(y mod 400<>0) then d:=28 else
d:=29;
end;
writeln(d);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
