Вопрос задан 17.06.2019 в 17:05.
Предмет Информатика.
Спрашивает Sargga Lena.
Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент,
находящийся в центре должен быть посчитан лишь один раз. Нужно написать программу.Ответы на вопрос
Отвечает Клыкова Арина.
Var matrix: array[1..5,1..5] of integer; i, j: integer; sg:=0; sp:=0;begin writeln ('Введите 25 чисел: '); for i := 1 to 5 do for j := 1 to 5 do read (matrix[i,j]); for i := 1 to 5 do begin for j := 1 to 5 do write (matrix[i,j], ' '); writeln end; for i:=1 to 5 do begin for j:= 1 to 5 do if j=i then sg:=sg+matrix[i,j]; end; for i:=5 downto 1 do begin for j:=1to 5 do if (i+j)=6 then sp:=sp+matrix[i,j] end; sp:=sp-matrix[3,3];1 writeln(sg,' ',sp);readlnend.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
