Вопрос задан 17.06.2019 в 05:28.
Предмет Информатика.
Спрашивает Биев Никита.
составить программу на паскаль: Имеются сведения о 40-и регионах страны: название региона и
информация об уровне безработицы в регионе. Определите три наиболее благополучных и три неблагополучных районаОтветы на вопрос
Отвечает Димов Дима.
A:array[1..40] of string;
b:array[1..40] of integer;{буду считать что информация по безработице-число}
i, n, j, m:integer;
begin
for i:=1 to 40 do
readln(a[i]);
readln(b[i]);
for i:=1 to 40 do
for j:=1 to 40 do
if b[i]>b[j] then begin
n:=a[i]; a[i]:=a[j]; a[j]:=n;
m:=b[i]; b[i]:=b[j]; b[j]:=m; end;
writeln('неблагополучные регионы:');
for i:=1 to 3 do
writeln(a[i],' ',b[i]);
writeln('благополучные регионы:');
for i:=40 downto 38 do
writeln(a[i],' ',b[i]);
readln;
end.
b:array[1..40] of integer;{буду считать что информация по безработице-число}
i, n, j, m:integer;
begin
for i:=1 to 40 do
readln(a[i]);
readln(b[i]);
for i:=1 to 40 do
for j:=1 to 40 do
if b[i]>b[j] then begin
n:=a[i]; a[i]:=a[j]; a[j]:=n;
m:=b[i]; b[i]:=b[j]; b[j]:=m; end;
writeln('неблагополучные регионы:');
for i:=1 to 3 do
writeln(a[i],' ',b[i]);
writeln('благополучные регионы:');
for i:=40 downto 38 do
writeln(a[i],' ',b[i]);
readln;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
