
Вопрос задан 17.06.2019 в 03:20.
Предмет Информатика.
Спрашивает Броневицкая Илона.
Помогите с Turbo Pascal.. Надо написать программу Напишите программу Генератором случайных чисел
генерируется последовательность 50-ти случайных чисел из диапазона [-10;20]. Вычислить сумму положительных элементов последовательности, порядковые номера которых нечетны.

Ответы на вопрос

Отвечает Лисова Алиса.
Var x: array[1..50] of longint;
var i,a : longint;
Begin
randomize;
for i:= 1 to 50 do
begin;
x[i] := -10 + random(30);
writeln('Элемент №',i,' массива Х = ',x[i]);
end;
for i:=1 to 50 do
begin;
if (i mod 2 <> 0) then a:=a+x[i];
end;
Writeln('Сумма элементов с нечетным номером = ',a);
readln(a);
end.
//Я поверил ей на слова, что сумма равна именно такому числу. Если хотите - проверьте.
//Пример работы программы в приложении
var i,a : longint;
Begin
randomize;
for i:= 1 to 50 do
begin;
x[i] := -10 + random(30);
writeln('Элемент №',i,' массива Х = ',x[i]);
end;
for i:=1 to 50 do
begin;
if (i mod 2 <> 0) then a:=a+x[i];
end;
Writeln('Сумма элементов с нечетным номером = ',a);
readln(a);
end.
//Я поверил ей на слова, что сумма равна именно такому числу. Если хотите - проверьте.
//Пример работы программы в приложении


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili