Вопрос задан 16.06.2019 в 02:35.
Предмет Информатика.
Спрашивает Bobnyuk Jana.
Напишите программу(в Паскаль) нахождения суммы S=1+1/2+1/3+...1/n, где n - натуральное число.
Ответы на вопрос
Отвечает Бугаенко Паша.
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
Writeln(SeqGen(ReadInteger('n='),x->1/x,1).Sum)
end.
Тестовое решение:
n= 20
3.59773965714368
begin
Writeln(SeqGen(ReadInteger('n='),x->1/x,1).Sum)
end.
Тестовое решение:
n= 20
3.59773965714368
Отвечает Крюкова Алина.
Var n,s:real;
begin
readln(n);
s:=1;
for var i:=2 to n do s:=s+1/i;
writeln('s=',s);
end.
begin
readln(n);
s:=1;
for var i:=2 to n do s:=s+1/i;
writeln('s=',s);
end.
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
