Вопрос задан 12.06.2019 в 20:43.
Предмет Информатика.
Спрашивает Потапов Стас.
Pascal нужно написать программу с алгоритмом 3.1 и 3.2 , 6 Нужно очень очень. Подробно если можно


Ответы на вопрос
Отвечает Нафанова Полина.
3.1
var
x, a, b, c: real;
begin
readln(x, a, b, c);
writeln('y = ', (sqr(a - 4) * (1 / (x * x * x)) - 3 * sqr(b) * x) / (a * x + b) + 3 * (1 / sqr(a)) - ln(x));
end.
3.2
var
a, h, b, c: real;
begin
readln(a, h);
c := 2 * sqrt(sqr(a) - sqr(h));
b := a;
writeln('P = ', a + b + c);
writeln('S = ', 0.5 * sqr(a));
end.
6
var
n, t: byte;
g: integer;
begin
readln(n);
for i: byte := 1 to n do
begin
readln(t);
g := g + t;
end;
writeln(g / n:0:1, ' г.');
end.
var
x, a, b, c: real;
begin
readln(x, a, b, c);
writeln('y = ', (sqr(a - 4) * (1 / (x * x * x)) - 3 * sqr(b) * x) / (a * x + b) + 3 * (1 / sqr(a)) - ln(x));
end.
3.2
var
a, h, b, c: real;
begin
readln(a, h);
c := 2 * sqrt(sqr(a) - sqr(h));
b := a;
writeln('P = ', a + b + c);
writeln('S = ', 0.5 * sqr(a));
end.
6
var
n, t: byte;
g: integer;
begin
readln(n);
for i: byte := 1 to n do
begin
readln(t);
g := g + t;
end;
writeln(g / n:0:1, ' г.');
end.
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
