Вопрос задан 11.06.2019 в 18:20.
Предмет Информатика.
Спрашивает Меняйлов Ваня.
Составить программу вставки в массив A(N) первого элемента, равного 7
Ответы на вопрос
Отвечает Москоленко Нелля.
var a:array [1..100] of integer;
i,n:integer;
Begin
read(n);
for i:= 1 to n do
read(a[i]);
for i:= n downto 1 do
a[i+1]:=a[i];
a[1]:=7;
for i:=1 to n+1 do
write(a[i],' ');
End.
Отвечает Гардиш Даринка.
Program R1;
Var a:array[1..100] of integer;
i,n:integer;
begin
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln(n);
for i:=1 to n do read(a[i]);
for i:=n+1 downto 2 do
a[i]:=a[i-1] ;
a[1]:=7 ;
for i:=1 to n+1 do write(a[i],' ');
close(input);
close(output);
end.
например
ввод
4
1 2 3 4
вывод
7 1 2 3 4
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
