Вопрос задан 20.05.2018 в 08:25. Предмет Информатика. Спрашивает Автайкин Максим.

Составьте программу нахождения площади равнобедрянной трапеции через стороны a,b,c (вопрос 10)


0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Штокибас Дробиус.

//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var (a,b,c):=ReadReal3();
write('S=',((a+b)/2)*sqrt(c*c-((a-b)*(a-b)/4)));
end.

0 0
Отвечает Лычкина Арина.

// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('a,b - большее и меньшее основания равнобедренной трапеции');
  Writeln('с - боковая сторона этой трапеции. Вычисляется площадь S');
  var (a,b,c):=ReadReal3('Введите a,b,c через пробел:');
  var s:=(a+b)/2*Sqrt(c*c-Sqr(a-b)/4);
  Writeln('S=',s:0:4)
end.

Пример
a,b - большее и меньшее основания равнобедренной трапеции
с - боковая сторона этой трапеции. Вычисляется площадь S
Введите a,b,c через пробел: 6 4.5 2.7
S=13.6171

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос