Вопрос задан 04.06.2019 в 08:39. Предмет Информатика. Спрашивает Сафронов Никита.

Напишите программу, которая считает сумму цифр введённого числа. Язык Python. Спасибо,кто поможет

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дмитрева Лиза.
Ну я бы на Питоне сделал бы это так:

n = input()
s = 0
for i in n:
    s += int(i)
print("Сумма цифр:", s)

Небольшая хитрость. На входе получаем не число, а строку. А дальше каждый символ строки переводим в цифру и суммируем.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос