Вопрос задан 03.06.2019 в 14:12.
Предмет Информатика.
Спрашивает Щеглов Максим.
Напишите программу в которой определяется сумма S всех целых чисел в интервале заданном переменами
N и M а так же сумма SA четных и SB нечетных в этомже интервалеОтветы на вопрос
Отвечает Маратова Рабига.
Язык С#
код:
using System;namespace ConsoleApp95{ class Program { static void Main(string[] args) { int N, M,S = 0 ,SB = 0 ,SA = 0 ; N = Convert.ToInt32(Console.ReadLine()); M = Convert.ToInt32(Console.ReadLine()); for ( int i = N+1; i < M; i++) { if ( i % 2 == 0 ) { S += i; SA += i; } else { SB += i; } } Console.WriteLine(S + " " + SA + " " + SB); Console.ReadKey(); } }}
код:
using System;namespace ConsoleApp95{ class Program { static void Main(string[] args) { int N, M,S = 0 ,SB = 0 ,SA = 0 ; N = Convert.ToInt32(Console.ReadLine()); M = Convert.ToInt32(Console.ReadLine()); for ( int i = N+1; i < M; i++) { if ( i % 2 == 0 ) { S += i; SA += i; } else { SB += i; } } Console.WriteLine(S + " " + SA + " " + SB); Console.ReadKey(); } }}
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
