
Вопрос задан 02.06.2019 в 17:46.
Предмет Информатика.
Спрашивает Шишкин Родион.
Помогите пожалуйста!!! Задача на Paskal Напишите программу, которая вычесляет среднюю температуру
воздуха за 10 дней, выведит на экран max и min значение температуры. Данные вводятся с клавиатуры.

Ответы на вопрос

Отвечает Трубников Глеб.
Var A:array [1..10] of integer;
b,min,max,i:integer;
c:real;
begin
b:=0;
c:=0;
for i:=1 to 10 do readln(A[i]);
for i:=1 to 10 do b:=b+A[i];
c:=b/10;
min:=A[1];
max:=A[1];
for i:=1 to 10 do
if A[i]<min then min:=A[i];
for i:=1 to 10 do
if A[i]>max then max:=A[i];
writeln(c);
writeln(min);
writeln(max);
end.
b,min,max,i:integer;
c:real;
begin
b:=0;
c:=0;
for i:=1 to 10 do readln(A[i]);
for i:=1 to 10 do b:=b+A[i];
c:=b/10;
min:=A[1];
max:=A[1];
for i:=1 to 10 do
if A[i]<min then min:=A[i];
for i:=1 to 10 do
if A[i]>max then max:=A[i];
writeln(c);
writeln(min);
writeln(max);
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili