
Вопрос задан 01.06.2019 в 05:08.
Предмет Информатика.
Спрашивает Буткус Алеша.
Написать программу поиска минимального значения в массиве, вывести на экран минимальное значение и
номер (индекс) этого значения.

Ответы на вопрос

Отвечает Кузнецов Илья.
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
var i:=a.IndexMin;
Writeln('Минимальный элемент ',a[i],' имеет индекс ',i+1)
end.
Пример
n= 15
66 -91 75 27 7 -95 96 48 -35 77 49 71 -13 25 -8
Минимальный элемент -95 имеет индекс 6
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
var i:=a.IndexMin;
Writeln('Минимальный элемент ',a[i],' имеет индекс ',i+1)
end.
Пример
n= 15
66 -91 75 27 7 -95 96 48 -35 77 49 71 -13 25 -8
Минимальный элемент -95 имеет индекс 6


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili