Вопрос задан 19.05.2018 в 01:14. Предмет Информатика. Спрашивает Небесов Глеб.

ДЛЯ ПИТОНА Секретное агентство «Super-Secret-no» решило для шифрования переписки своих сотрудников

использовать «метод бутерброда». Сначала буквы слова нумеруются в таком порядке: первая буква получает номер 1, последняя буква - номер 2, вторая – номер 3, предпоследняя – номер 4, потом третья … и так для всех букв (см. рисунок). Затем все буквы записываются в шифр в порядке своих номеров. В конец зашифрованного слова добавляется знак «диез» (#), который нельзя использовать в сообщениях. Например, слово «sandwich» зашифруется в «shacnidw#». К сожалению, программист «Super-Secret-no», написал только программу шифрования и уволился. И теперь агенты не могут понять, что же они написали друг другу. Помогите им. Входные данные Вводится слово, зашифрованное методом бутерброда. Длина слова не превышает 20 букв. Выходные данные Выведите расшифрованное слово. Примеры входные данные Aabrrbaacda# выходные данные Abracadabra
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Федів Антон.

Input_str = input('Введите строку: ')
output_str = ''

for i in range(0, len(input_str)-1, 2): 
    output_str += input_str[i]

temp = ''
for i in range(1, len(input_str)-1, 2):
  temp += input_str[i]

output_str += temp[::-1]  #Т.к. вторая часть задом наперед, нам надо делать ее реверс

print(output_str)

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос