
Вопрос задан 17.05.2018 в 15:59.
Предмет Информатика.
Спрашивает Снитко Даниил.
Написать программу через цикл WHILE "Найти произведение:P=(1+x) *(3+2x) *(5+3x)... (n множителей).
СРОЧНО!!! Заранее спасибо)

Ответы на вопрос

Отвечает Сквородин Михаил.
Var
n: integer;
x:real;
p:double;
begin
Writeln('Введите n и x');
Read(n);Readln(x);p:=1;
while (n > 0) do
begin
p:= p * (1 + 2*(n-1) + n*x);
n:= n - 1;
end;
Writeln(p);
end.
Пример:
Введите n и x
3 2
231


Топ вопросов за вчера в категории Информатика

Информатика 558

Информатика 33

Информатика 74

Информатика 12

Информатика 10

Информатика 33

Информатика 27
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili