Вопрос задан 22.05.2019 в 09:56.
Предмет Информатика.
Спрашивает Анисимов Максим.
Напишите программу в pascal abc Для первых n двузначных натуральных чисел вывести суммы цифр
каждого числаОтветы на вопрос
Отвечает Ильин Вадим.
Var S,n,A:integer;
Begin
Write('n = ');ReadLn(n);
For n:= 10 to n+9 do
Begin
A:=n;
S:=0;
While A > 0 do
Begin
S:=S+A mod 10;
A:= A div 10
End;
WriteLn('Сумма цифр ',n,' равна: ',S)
End;
End.
Begin
Write('n = ');ReadLn(n);
For n:= 10 to n+9 do
Begin
A:=n;
S:=0;
While A > 0 do
Begin
S:=S+A mod 10;
A:= A div 10
End;
WriteLn('Сумма цифр ',n,' равна: ',S)
End;
End.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
