Вопрос задан 21.05.2019 в 16:10.
Предмет Информатика.
Спрашивает Богданов Сергей.
Помогите написать программу в СИ++.Задача такая : Если сумма трёх попарно различных действительных
чисел x,y,z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. Заранее спасибо))Ответы на вопрос
Отвечает Surnina Nastya.
//Dev-C++ 5.11
#include <iostream>
using namespace std;
int main(void)
{float x,y,z=0;
cin>>x>>y>>z;
if(x+y+z<1)
{float min=x;
if (min>y) min=y;
if (min>z) min=z;
if (min==x) x=(y+z)/2;
if (min==y) y=(x+z)/2;
if (min==z) z=(x+y)/2;}
else
if(x>y) y=(x+z)/2; else x=(y+z)/2;
cout<<x<<" "<<y<<" "<<z<<" ";
return 0;}
Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
#include <iostream>
using namespace std;
int main(void)
{float x,y,z=0;
cin>>x>>y>>z;
if(x+y+z<1)
{float min=x;
if (min>y) min=y;
if (min>z) min=z;
if (min==x) x=(y+z)/2;
if (min==y) y=(x+z)/2;
if (min==z) z=(x+y)/2;}
else
if(x>y) y=(x+z)/2; else x=(y+z)/2;
cout<<x<<" "<<y<<" "<<z<<" ";
return 0;}
Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
