
Вопрос задан 21.05.2019 в 06:53.
Предмет Информатика.
Спрашивает Молдахан Аяжан.
Напишите программу на Паскале.Для заданных чисел X и N вычислите Z=X^N=X*X...X.X*X...X=N


Ответы на вопрос

Отвечает Рязанская Лиза.
var
x,n,x1 : real;
begin
readln(x,n);
x1:=abs(x);
if x<0 then writeln(-1*exp(n*ln(x1)):0:0)
else writeln(exp(n*ln(x)):0:0);
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili