
Вопрос задан 16.05.2018 в 17:04.
Предмет Информатика.
Спрашивает Лисицына Дарья.
Написать программу.Дана матрица А, имеющая N строк и N столбцов. Сформируйте два одномерных
массива. В один перешлите четные, а в другой — нечетные элементы матрицы. Выведите на экран все массивы.помогите пожалуйста. пожалуйста срочна нужна помощь

Ответы на вопрос

Отвечает Кирилова Екатерина.
Const n=5;
var a:array[1..n,1..n] of integer;
b,c:array[1..n*n] of integer;
k1,k2,i,j:integer;
begin
k1:=0;
k2:=0;
for i:=1 to n do
for j:=1 to n do begin
read(a[i,j]);
if odd(a[i,j]) then begin inc(k2); c[k2]:=a[i,j]; end
else begin inc(k1); b[k1]:=a[i,j]; end;
end;
writeln('Четные');
for i:=1 to k1 do
write(b[i],' ');
writeln();
writeln('Нечетные');
for i:=1 to k2 do
write(c[i],' ');
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili