Напишите программу на c#! Подсчитать количество нечетных цифр в заданном числе.
Ответы на вопрос
Конечно! Вот пример программы на C#, которая подсчитывает количество нечетных цифр в заданном числе:
```csharp using System;
class Program { static void Main(string[] args) { Console.Write("Введите число: "); int number = int.Parse(Console.ReadLine());
int oddCount = 0; while (number != 0) { int digit = number % 10; if (digit % 2 != 0) { oddCount++; } number /= 10; }
Console.WriteLine("Количество нечетных цифр: " + oddCount); } } ```
В этой программе мы считываем число с помощью `Console.ReadLine()` и преобразуем его в целое число с помощью `int.Parse()`. Затем мы используем цикл `while`, чтобы извлекать цифры из числа, начиная с младшего разряда. Если цифра нечетная (т.е. остаток от деления на 2 не равен 0), мы увеличиваем счетчик `oddCount`. Затем мы делим число на 10, чтобы перейти к следующей цифре. После завершения цикла мы выводим количество нечетных цифр на экран с помощью `Console.WriteLine()`.
Примечание: Предполагается, что пользователь вводит только положительные числа. Если вам нужно обрабатывать отрицательные числа или числа с десятичной частью, вам потребуется внести соответствующие изменения в программу.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
