
Написать программу для рассчета стоимости покупки из 5 предметов, если цена каждого из предметов
задается командой ввода. Программа должна быть понятна любому пользователю. turbo pascal

Ответы на вопрос

uses crt;
begin
writeln('Введите цену 1 товара:');
readln(p1);
writeln('Введите цену 2 товара:');
readln(p2);
writeln('Введите цену 3 товара:');
readln(p3);
writeln('Введите цену 4 товара:');
readln(p4);
writeln('Введите цену 5 товара:');
readln(p5);
writeln('Цена вашей покупки составляет ',p1+p2+p3+p4+p5);
end.
P.S. Надеюсь на Лучший ответ.



Вот пример программы на Turbo Pascal, которая рассчитывает стоимость покупки из 5 предметов:
```pascal program CalculatePurchaseCost;
var price1, price2, price3, price4, price5: real; totalCost: real;
begin writeln('Введите цену первого предмета:'); readln(price1); writeln('Введите цену второго предмета:'); readln(price2); writeln('Введите цену третьего предмета:'); readln(price3); writeln('Введите цену четвертого предмета:'); readln(price4); writeln('Введите цену пятого предмета:'); readln(price5); totalCost := price1 + price2 + price3 + price4 + price5; writeln('Общая стоимость покупки:', totalCost:0:2); readln; end. ```
Программа начинается с объявления переменных: `price1`, `price2`, `price3`, `price4`, `price5` для хранения цен каждого из предметов, а также `totalCost` для хранения общей стоимости покупки.
Затем программа запрашивает у пользователя ввод цены каждого из предметов с помощью команды `readln`. После ввода всех цен, программа суммирует их и сохраняет результат в переменной `totalCost`.
Наконец, программа выводит общую стоимость покупки с помощью команды `writeln`.
Программа ожидает, пока пользователь нажмет клавишу Enter, прежде чем завершить свою работу.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili