Составьте программу, по которой будет реализованследующий сценарий: компьютер запрашивает номер дня
недели, после ввода компьютер сообщает название этого дня. Например, если ввели 1, то выведется фраза" Это понедельник" ит.д.Ответы на вопрос
var a:integer;
begin
writeln('Days Of Week');
readln(a);
case a of
1: write('Monday');
2: write('Tuesday');
3: write('Wednesday');
4: write('Thursday');
5: write('Friday');
6: write('Saturday');
7: write('Sunday');
end;
end.
Приведенный сценарий можно реализовать с помощью программы на языке Python. Вот пример такой программы:
```python # Запрос номера дня недели от пользователя day_number = int(input("Введите номер дня недели (1-7): "))
# Проверка введенного номера и вывод соответствующего сообщения if day_number == 1: day_name = "понедельник" elif day_number == 2: day_name = "вторник" elif day_number == 3: day_name = "среда" elif day_number == 4: day_name = "четверг" elif day_number == 5: day_name = "пятница" elif day_number == 6: day_name = "суббота" elif day_number == 7: day_name = "воскресенье" else: day_name = "некорректный номер дня"
# Вывод результата print("Это", day_name) ```
Пользователю будет предложено ввести номер дня недели от 1 до 7. Затем программой будет проведена проверка введенного числа и в зависимости от результата будет выведено соответствующее название дня недели. Если введен некорректный номер, программа выведет сообщение "некорректный номер дня".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
