
Вопрос задан 10.05.2019 в 23:30.
Предмет Информатика.
Спрашивает Ганин Никита.
Составить программу, которая позволяет найти сумму первой и третьей цифры в четырехзначном числе.


Ответы на вопрос

Отвечает Живкин Пётр.
#include <iostream>
using namespace std;
int main(){
system("chcp 1251");
int n;
cout<<"введите 4-значное число";
cin >> n;
int first = n/1000; // первая цифра
int third = (n%100)/10;
cout << "\nОтвет = " << first + third << endl;
system("pause");
}
using namespace std;
int main(){
system("chcp 1251");
int n;
cout<<"введите 4-значное число";
cin >> n;
int first = n/1000; // первая цифра
int third = (n%100)/10;
cout << "\nОтвет = " << first + third << endl;
system("pause");
}



Отвечает Головко Егор.
Program test_sum;
begin
var inp_num : integer;
readln (inp_num);
var a, b : integer;
a := inp_num[0];
b := inp_num[2];
var res := a + b;
writeln ("Сумма 1 и 3 цифры равна: ", res);
end.
begin
var inp_num : integer;
readln (inp_num);
var a, b : integer;
a := inp_num[0];
b := inp_num[2];
var res := a + b;
writeln ("Сумма 1 и 3 цифры равна: ", res);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам составить программу, которая позволяет найти сумму первой и третьей цифры в четырехзначном числе. Вот один из возможных вариантов решения этой задачи на языке Python:
```python # Вводим четырехзначное число number = int(input("Введите четырехзначное число: "))
# Проверяем, что число действительно четырехзначное if 1000 <= number <= 9999: # Извлекаем первую и третью цифры first_digit = number // 1000 third_digit = (number // 100) % 10
# Находим сумму первой и третьей цифры sum = first_digit + third_digit
# Выводим результат print("Сумма первой и третьей цифры равна", sum) else: # Выводим сообщение об ошибке print("Число должно быть четырехзначным") ```
Надеюсь, это вам поможет.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili