Вопрос задан 10.05.2019 в 01:49. Предмет Информатика. Спрашивает Панченко Ростислав.

Составить программу обработки массива F(21). Каждый третий элемент массива F возвести в квадрат,

если элемент отрицательный. Эти значения напечатать. Pascalabc( 9 класс)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Иванов Дима.
Var
  i: integer;
  f: array[1..21] of integer;
begin
  randomize;
  for i := 1 to 12 do 
  begin
    f[i]:=random(21)-10;
    if (i mod 3 = 0)and(f[i]<0) then f[i]:=sqr(f[i]);
    writeln(f[i]);
  end;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке PascalABC для обработки массива F(21), где каждый третий отрицательный элемент возводится в квадрат, может выглядеть следующим образом:

```pascal program ProcessArray;

const N = 21; // Размер массива

var F: array[1..N] of Integer; i, countNegatives: Integer;

begin // Инициализация массива F случайными значениями (можно ввести с клавиатуры или задать иначе) Randomize; for i := 1 to N do F[i] := Random(100) - 50; // Генерация случайных чисел от -50 до 49

// Вывод исходного массива writeln('Исходный массив F:'); for i := 1 to N do write(F[i], ' ');

writeln; writeln('Элементы, возводимые в квадрат:'); countNegatives := 0; // Счетчик отрицательных элементов // Обработка массива: каждый третий отрицательный элемент возводим в квадрат for i := 1 to N do begin if (F[i] < 0) then begin countNegatives := countNegatives + 1; if (countNegatives mod 3 = 0) then // Каждый третий отрицательный элемент begin F[i] := F[i] * F[i]; // Возводим в квадрат writeln(F[i]); // Выводим значение end; end; end;

writeln; writeln('Итоговый массив F после обработки:'); // Вывод итогового массива for i := 1 to N do write(F[i], ' ');

end. ```

Эта программа создает массив F размером 21 элемент и заполняет его случайными значениями от -50 до 49. Затем программа проходит по массиву, и каждый третий отрицательный элемент возводит в квадрат, выводя эти значения. Наконец, программа выводит исходный массив и массив после обработки.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос