Вопрос задан 10.05.2019 в 01:27. Предмет Информатика. Спрашивает Смотрин Вова.

ЗАДАЧА В ПАСКАЛЕдана непустая последовательность целых чисел оканчивающаяся нулем.найти:а)

наибольшее числоб) разность максимального и минимальногов) максимальный элемент из стоящих на четных местахг) сумму положительных и среднее арифметическое отрицательныхд) второй максимуме) длину наибольшего фрагмента, состоящего из одинаковых элементов.ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО ЗА РЕШЕНИЕ ХОТЯ БЫ ОДНОЙ ИЗ ЗАДАЧЕК...))))))
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Утриванов Артем.

a)

program name;
var a,b,c:integer;
begin
c:=0;
readln(a,b);
If (a>b+c) then writeln('Наибольшее число: ' , a)
else if (a<b+c) then writeln('Наибольшее число: ' , b)
else write();

readln();  // взависимости от компилятора.
end.

 

Сейчас ещё что-нибудь решу!

 

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задача в Паскале

Дана непустая последовательность целых чисел, оканчивающаяся нулем. Вам нужно найти следующие значения:

а) Наибольшее число: Для этого нужно пройти по всей последовательности и сохранить наибольшее число, которое встретится. В конце прохода выведите это число.

б) Разность максимального и минимального чисел: Пройдите по всей последовательности и сохраните наименьшее и наибольшее число. Затем найдите разность между ними и выведите результат.

в) Максимальный элемент из чисел, стоящих на четных местах: Пройдите по всей последовательности, начиная с первого элемента, и сохраните максимальное число, которое стоит на четном месте (индексе). Выведите это число.

г) Сумма положительных чисел и среднее арифметическое отрицательных чисел: Пройдите по всей последовательности и сохраните сумму всех положительных чисел. Затем найдите среднее арифметическое отрицательных чисел (сумма отрицательных чисел, деленная на их количество). Выведите оба значения.

д) Второй максимум: Пройдите по всей последовательности и найдите наибольшее число. Затем пройдите по последовательности еще раз и найдите второе наибольшее число (которое не равно максимальному числу). Выведите второй максимум.

е) Длина наибольшего фрагмента, состоящего из одинаковых элементов: Пройдите по всей последовательности и найдите самый длинный фрагмент, состоящий из одинаковых элементов. Выведите его длину.

Ниже приведен пример кода на языке Паскаль, который решает данную задачу:

```pascal program SequenceProblem;

var number, maxNumber, minNumber, evenMax, positiveSum, negativeCount, negativeSum, secondMax, currentLength, maxLength: integer; previousNumber, currentNumber: integer; isFragment: boolean;

begin maxNumber := -1000000; // Задаем начальные значения переменных minNumber := 1000000; evenMax := -1000000; positiveSum := 0; negativeCount := 0; negativeSum := 0; secondMax := -1000000; currentLength := 1; maxLength := 1; isFragment := false;

repeat readln(number); // Считываем число из входной последовательности

// а) Наибольшее число if number > maxNumber then maxNumber := number;

// б) Разность максимального и минимального чисел if number < minNumber then minNumber := number;

// в) Максимальный элемент из чисел, стоящих на четных местах if currentLength mod 2 = 0 then begin if number > evenMax then evenMax := number; end;

// г) Сумма положительных чисел и среднее арифметическое отрицательных чисел if number > 0 then positiveSum := positiveSum + number else if number < 0 then begin negativeSum := negativeSum + number; negativeCount := negativeCount + 1; end;

// д) Второй максимум if number > secondMax then begin secondMax := number; end;

// е) Длина наибольшего фрагмента, состоящего из одинаковых элементов if currentNumber = number then begin currentLength := currentLength + 1; if currentLength > maxLength then maxLength := currentLength; end else begin currentNumber := number; currentLength := 1; end;

// Проверяем, является ли текущий фрагмент самым длинным if currentLength > maxLength then maxLength := currentLength;

until number = 0; // Продолжаем цикл, пока не встретим ноль

writeln('Наибольшее число: ', maxNumber); writeln('Разность максимального и минимального чисел: ', maxNumber - minNumber); writeln('Максимальный элемент из чисел, стоящих на четных местах: ', evenMax); writeln('Сумма положительных чисел: ', positiveSum); writeln('Среднее арифметическое отрицательных чисел: ', negativeSum / negativeCount); writeln('Второй максимум: ', secondMax); writeln('Длина наибольшего фрагмента, состоящего из одинаковых элементов: ', maxLength);

end. ```

Пожалуйста, обратите внимание, что код предоставлен только в качестве примера и может потребовать некоторых изменений для вашей конкретной задачи.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос