Прошу вас помогите пожалуйста написать программу на Паскале АВС. Дана строка из строчных русских
букв, между соседними словами запятая, за последним словом точка. Составить программу, печатающую в алфавитном порядке: Все согласные буквы, которые не входят ни в одно слово.Ответы на вопрос
Программа на Паскале для печати согласных букв, которые не входят в слова
Вот пример программы на языке Паскаль, которая позволяет печатать все согласные буквы, которые не входят в заданную строку:
```pascal program PrintConsonantsNotInWords;
var inputString: string; consonants: string; i, j: integer; found: boolean;
begin // Ввод строки writeln('Введите строку:'); readln(inputString);
// Определение всех согласных букв consonants := 'бвгджзйклмнпрстфхцчшщ';
// Поиск согласных букв, которые не входят в слова writeln('Согласные буквы, которые не входят в слова:'); for i := 1 to length(consonants) do begin found := false; for j := 1 to length(inputString) do begin if (inputString[j] = consonants[i]) then begin found := true; break; end; end; if (not found) then write(consonants[i]); end;
writeln; readln; end. ```
Программа запрашивает у пользователя ввод строки и затем ищет все согласные буквы, которые не входят в слова в этой строке. Результат выводится в алфавитном порядке.
Примечание: В данном примере предполагается, что вводимая строка содержит только строчные русские буквы, запятые между словами и точку в конце последнего слова. Если ввод может содержать другие символы, то код программы нужно будет дополнить соответствующими проверками.
Надеюсь, эта программа поможет вам решить вашу задачу! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
