Вопрос задан 09.05.2019 в 04:16. Предмет Информатика. Спрашивает Степанов Степан.

Помогите пожалуйста ) Надо написать программу на Pascal ) Суть заключается в следующем, программа

должна выводить в итоге, вот такие вот значения (цикл должен присутствовать) 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Николаева Татьяна.
Var
 a,j,i:integer;
begin
for i:=1 to 4 do
 begin  a:=i;
  for j:=1 to 4 do
  begin
   write(a,' ');
   a:=a+i;
  end;
 writeln;
 end;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Привет! Я могу помочь тебе написать программу на Pascal, которая будет выводить такие значения. Вот пример кода:

```pascal program OutputValues;

var i, j: integer;

begin j := 1; for i := 1 to 4 do begin writeln(j); writeln(j * 2); writeln(j * 3); writeln(j * 4); j := j + 1; end; end. ```

В этом коде используется цикл `for`, который выполняется 4 раза. Переменная `j` инициализируется со значением 1, и на каждой итерации она увеличивается на 1. Внутри цикла выводятся значения `j`, `j * 2`, `j * 3` и `j * 4` с помощью процедуры `writeln`.

Если ты запустишь эту программу, то она выведет следующие значения:

``` 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16 ```

Надеюсь, это поможет! Если у тебя возникнут еще вопросы, не стесняйся задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос