Вопрос задан 09.05.2019 в 01:09. Предмет Информатика. Спрашивает Кучерявий Бодя.

Написать программу по паскале по файлам: ИЗ ОДНОГО ФАЙЛА СКОПИРОВАТЬ В ДРУГОЙ ФАЙЛ. пожалуйста

решите до завтра надо((
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Савченко Каролина.
Var a,b:longint;
c:text;
begin
assign(c, 'Input.txt');
reset(c);
read(c,a,b);
close(c);
assign(c, 'Output.txt');
rewrite(c);
writeln(c,a,' ',b);
close(c);
end.

P.S. в файле 
Input.txt введены 2 числа через пробел, эти же числа копируются в Output.txt, для проверки программы, создавай папку и 2 файла Input.txt и Output.txt, далее копируй текст программы в паскаль и сохраняй программу в ту папку где 2 файла в формате паскаля (*.pas), и запускай программу, числа из текстового документа Input копируются в Output
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

К сожалению, я не могу написать полный код программы за вас, но я могу предоставить вам пример простой программы на Pascal, которая копирует содержимое одного файла в другой. Помните, что для копирования файлов вам потребуется открыть файлы, читать их содержимое и записывать его в другой файл.

Пример программы на Pascal:

```pascal program CopyFile;

var inputFile, outputFile: file of char; inputFileName, outputFileName: string; ch: char;

begin // Ввод имени входного файла write('Введите имя входного файла: '); readln(inputFileName);

// Открытие входного файла для чтения assign(inputFile, inputFileName); reset(inputFile);

// Проверка наличия входного файла if IOResult <> 0 then begin writeln('Ошибка открытия входного файла.'); halt; end;

// Ввод имени выходного файла write('Введите имя выходного файла: '); readln(outputFileName);

// Открытие выходного файла для записи assign(outputFile, outputFileName); rewrite(outputFile);

// Проверка наличия выходного файла if IOResult <> 0 then begin writeln('Ошибка открытия выходного файла.'); close(inputFile); halt; end;

// Чтение из входного файла и запись в выходной файл while not eof(inputFile) do begin read(inputFile, ch); write(outputFile, ch); end;

// Закрытие файлов close(inputFile); close(outputFile);

writeln('Копирование завершено.'); end. ```

Прежде чем запустить эту программу, убедитесь, что у вас есть права на чтение и запись файлов в соответствующих директориях. Также, помните, что данная программа копирует файл символ за символом и не является оптимальным решением для больших файлов.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос