
Напишите программу для нахождения значения арифметического выражения: p=1/2*(a+b+c). На примере
BorlandPascal.

Ответы на вопрос




Я могу помочь вам написать программу для нахождения значения арифметического выражения: p=1/2*(a+b+c). На примере Borland Pascal, программа может выглядеть так:
```pascal program expression; var a, b, c, p: real; // объявляем переменные типа вещественное число begin writeln('Введите значения сторон треугольника a, b и c через пробел:'); // выводим сообщение на экран readln(a, b, c); // считываем значения переменных с клавиатуры p := 0.5 * (a + b + c); // вычисляем значение выражения и присваиваем его переменной p writeln('Значение выражения p = 1/2 * (a + b + c) равно ', p:0:2); // выводим результат на экран с двумя знаками после запятой end. ```
Эта программа позволяет найти полупериметр треугольника по формуле Герона. Вы можете запустить эту программу в онлайн-компиляторе Borland Pascal и проверить ее работу. Надеюсь, это было полезно для вас.
: [Формула Герона — Википедия] : [Online Pascal Compiler - Online Pascal Editor - Online Pascal IDE - Pascal Coding Online - Practice Pascal Online - Execute Pascal Online - Compile Pascal Online - Run Pascal Online]


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili