Вопрос задан 07.05.2019 в 16:12. Предмет Информатика. Спрашивает Шлык Полина.

1 написать программу которая проверяет на кратность 5 произведение цифр двузначного числа вводимого

с клавиатуры в ответе написать ДА или НЕТ. 2 написать программу которая удваивает наибольшую цифру двузначного целого числа результат на экран. 3 написать программу которая утраивает четные цифры двузначного числа результат на экран.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Байболов Данияр.
1.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1*a2 mod 5 = 0
 then writeln('Да') else writeln('Нет');
end.

Пример:
a = 52
Да

2.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1>a2
 then writeln('2*',a1,' = ',2*a1) else writeln('2*',a2,' = ',2*a2);
end.

Пример:
a = 93
2*9 = 18

3.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1 mod 2 = 0 then writeln('3*',a1,' = ',3*a1);
if a2 mod 2 = 0 then writeln('3*',a2,' = ',3*a2);
end.

Пример:
a = 45
3*4 = 12
0 0
Отвечает Варагушина Даша.
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

№1
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  if (p*q) mod 5=0 then Writeln('Да')
  else Writeln('Нет')
end.

№2
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  Writeln(Max(p,q)*2)
end.

№3
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  if p.IsEven then p*=3;
  if q.IsEven then q*=3;
  Println(p,q)
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

1. Программа для проверки кратности 5 произведения цифр двузначного числа

Для написания программы, которая проверяет кратность 5 произведения цифр двузначного числа, можно использовать следующий алгоритм:

1. Запросить у пользователя ввод двузначного числа. 2. Разделить это число на десять и сохранить остаток от деления. 3. Умножить остаток от деления на следующую цифру числа. 4. Проверить, является ли результат кратным 5. 5. Вывести "ДА", если результат кратен 5, и "НЕТ" в противном случае.

Пример кода на языке Python:

```python number = int(input("Введите двузначное число: "))

digit1 = number % 10 digit2 = number // 10

product = digit1 * digit2

if product % 5 == 0: print("ДА") else: print("НЕТ") ```

2. Программа для удвоения наибольшей цифры двузначного числа

Для написания программы, которая удваивает наибольшую цифру двузначного числа, можно использовать следующий алгоритм:

1. Запросить у пользователя ввод двузначного числа. 2. Разделить это число на десять и сохранить остаток от деления. 3. Найти максимальную цифру из остатка и следующей цифры числа. 4. Удвоить максимальную цифру. 5. Заменить максимальную цифру в числе на удвоенную цифру. 6. Вывести результат на экран.

Пример кода на языке Python:

```python number = int(input("Введите двузначное число: "))

digit1 = number % 10 digit2 = number // 10

max_digit = max(digit1, digit2) doubled_digit = max_digit * 2

if digit1 == max_digit: number = doubled_digit * 10 + digit2 else: number = digit1 * 10 + doubled_digit

print("Результат:", number) ```

3. Программа для утраивания четных цифр двузначного числа

Для написания программы, которая утраивает четные цифры двузначного числа, можно использовать следующий алгоритм:

1. Запросить у пользователя ввод двузначного числа. 2. Разделить это число на десять и сохранить остаток от деления. 3. Проверить каждую цифру числа на четность. 4. Если цифра четная, утроить ее. 5. Заменить четную цифру в числе на утроенную цифру. 6. Вывести результат на экран.

Пример кода на языке Python:

```python number = int(input("Введите двузначное число: "))

digit1 = number % 10 digit2 = number // 10

if digit1 % 2 == 0: digit1 *= 3

if digit2 % 2 == 0: digit2 *= 3

number = digit2 * 10 + digit1

print("Результат:", number) ```

Обратите внимание: Во всех трех программах предполагается, что пользователь вводит двузначное число. Если пользователь вводит число с более чем двумя цифрами или с менее чем двумя цифрами, программа может дать некорректный результат.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос