Составить программу на паскале. Сформировать двумерный массив, состоящий из положительных и
потрицательных элементов.Заменить положительные элементы-еденицей, а отрицательные-нулемОтветы на вопрос
Const
n=3;
Var
ma:array[1..n,1..n] of integer;
i,j:integer;
begin
randomize;
writeln('Matrix:');
for i:=1 to n do
begin
for j:=1 to n do
begin
ma[i,j]:=random(-10,10);
write(ma[i,j]:4);
if ma[i,j]>0 then ma[i,j]:=1 else ma[i,j]:=0;
end;
writeln;
end;
writeln('Final matrix:');
for i:=1 to n do
begin
for j:=1 to n do
write(ma[i,j]:4);
writeln;
end;
end.
Пример работы программы:
Matrix:
-6 1 8
1 -8 5
6 9 6
Final matrix:
0 1 1
1 0 1
1 1 1
Конечно, вот пример программы на Pascal, которая создает двумерный массив, заполняет его случайными положительными и отрицательными числами, а затем заменяет положительные элементы единицей, а отрицательные - нулем:
```pascal program TwoDArrayExample;
const Rows = 3; // количество строк Cols = 3; // количество столбцов
var myArray: array[1..Rows, 1..Cols] of Integer; i, j: Integer;
// Процедура для заполнения массива случайными числами procedure FillArray; begin for i := 1 to Rows do for j := 1 to Cols do myArray[i, j] := Random(20) - 10; // генерация случайных чисел от -10 до 9 end;
// Процедура для замены положительных элементов единицей и отрицательных - нулем procedure ReplaceElements; begin for i := 1 to Rows do for j := 1 to Cols do begin if myArray[i, j] > 0 then myArray[i, j] := 1 else if myArray[i, j] < 0 then myArray[i, j] := 0; end; end;
// Процедура для вывода массива procedure PrintArray; begin for i := 1 to Rows do begin for j := 1 to Cols do Write(myArray[i, j], ' '); Writeln; end; end;
begin // Заполнение массива случайными числами FillArray;
// Вывод исходного массива Writeln('Исходный массив:'); PrintArray;
// Замена положительных элементов единицей и отрицательных - нулем ReplaceElements;
// Вывод измененного массива Writeln('Измененный массив:'); PrintArray; end. ```
Обратите внимание, что в этом примере массив заполняется случайными числами от -10 до 9, но вы можете изменить этот диапазон в соответствии с вашими потребностями.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
