
Помогите создать программу паскаль для задачи:Даны два различных вещественных числа.Определить
:а)Какое из них больше;б)Какое из них меньше;

Ответы на вопрос

a,b:real;
begin
readln(a,b);
if a=b then writeln('Они равны')
else if a>b then writeln(a,' больше ' ,b)
else writeln(b,' больше ' ,a);
end.



Конечно, я могу помочь вам написать программу на языке Pascal для решения этой задачи. Вот пример программы:
```pascal program CompareNumbers;
var num1, num2: real;
begin // Ввод двух вещественных чисел writeln('Введите первое вещественное число: '); readln(num1);
writeln('Введите второе вещественное число: '); readln(num2);
// Сравнение чисел и вывод результата if num1 > num2 then writeln('a) Первое число больше второго.') else if num1 < num2 then writeln('a) Второе число больше первого.') else writeln('a) Числа равны.');
if num1 < num2 then writeln('б) Первое число меньше второго.') else if num1 > num2 then writeln('б) Второе число меньше первого.') else writeln('б) Числа равны.');
readln; // Ждем, пока пользователь нажмет Enter перед закрытием программы end. ```
Эта программа запрашивает у пользователя два вещественных числа, затем сравнивает их и выводит результаты на экран. Программа сначала сравнивает числа по отношению "больше", а затем по отношению "меньше". Если числа равны, программа сообщит об этом.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili