Вопрос задан 07.05.2019 в 09:55.
Предмет Информатика.
Спрашивает Черников Александр.
4. Паскаль,помогите пожалуйста))) Составьте программу, выводящую на экран квадраты чисел от n до m
(n, m вводятся пользователем с клавиатуры).Ответы на вопрос
Отвечает Иванова Ангелина.
Program kvadratu;
var k,m,n,i:integer;
begin
Writeln('Введите n');
Writeln('Введите m');
Readln(n,m);
K:=(m-n);
Writeln(n*n);
for i:=1 to K do
begin
Writeln((n+1)*(n+1));
n:=n+1;
end;
end.
var k,m,n,i:integer;
begin
Writeln('Введите n');
Writeln('Введите m');
Readln(n,m);
K:=(m-n);
Writeln(n*n);
for i:=1 to K do
begin
Writeln((n+1)*(n+1));
n:=n+1;
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам с этим заданием. Вот программа на языке Pascal, которая выводит на экран квадраты чисел от n до m:
```pascal program PrintSquares; var n, m, i: integer; begin writeln('Введите значение n:'); readln(n); writeln('Введите значение m:'); readln(m); writeln('Квадраты чисел от ', n, ' до ', m, ':'); for i := n to m do begin writeln(i, ' * ', i, ' = ', i * i); end; readln; // Чтобы программа не закрывалась сразу после выполнения end. ```
Пользователь будет сначала приглашен ввести значение n, а затем значение m. Затем программа выведет на экран квадраты всех чисел от n до m, используя цикл `for`.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
